Home Forums Identity Governance Connector JDBC

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2725
    Davide Ceravolo
    Participant

    Good morning,
    In this days i’m testing the OpenIAM solution v4.2.0.9 and i need to use the JDBC connector; however, i’m experiencing the issue that you can see in the attached file containing the logs.
    Even using the available documentation i have not found a valid solution.
    Has anyone had the same issue or similar?
    Many thanks to all

    Attachments:
    You must be logged in to view attached files.
    #2728
    Neil Herbert
    Participant

    Hi Davide, welcome to the OpenIAM community!

    I will see what I can do to help, but you will need to provide more information.

    The error you are seeing suggests a timeout issue between OpenIAM, RabbitMQ and the JDBC Connector. OpenIAM posts messages/events onto RabbitMQ which are then picked up by connectors for processing. The error you’ve posted shows that OpenIAM isn’t receiving a response within the default timeout.

    • What you are trying to do when you see this error?
    • Have you run your search query directly on the database? If so how long does it take to complete?
    • Do you get a green timestamp next to the managed system that’s using the JDBC Connector?
    • How have you deployed OpenIAM? docker, rpm etc?
    • Have you deployed a JDBC connector within your environment?

    Neil

    #2729
    Davide Ceravolo
    Participant

    Hi Neil,
    Thank you for your reply,
    This is a test environment and the query is a simple SELECT * of 5 elements that require less than second to complete that from the cli.
    I don’t have a green timestamp because the error occurs during the connection verification phase.
    The deploy is on a VM with RedHat 8.5 with last update using the RPM package and mariadb 10.3
    SELinux is enabled, but doesn’t generate alerts or error.
    I tryed the default configuration except the credential of database and connection string.
    What do you mean with “deployed a JDBC connector within your environment”, i use the default mariadb connector offered by JDBC connector.

    #2730
    Neil Herbert
    Participant

    If it’s not able to verify the connection, it sounds like you might not have the JDBC connector started. Some connectors are not supplied or started with the base install. Take a look inside the /usr/local/openiam/connectors/bin/ folder and make sure the appropriate connector binary is present. You will then need to check that the connector has been started using the instructions at https://docs.openiam.com/docs-4.2.0.9/connectorconfig/1-registerconnector/2-rpm

    #2731
    Davide Ceravolo
    Participant

    I checked the directory and this should be it:
    oracle-connector-rabbitmq.jar
    I checked what state it was in via systemctl and it is running, but the error remains the same.
    I don’t know is JDBC require a different .jar file because i haven’t found any information about it.

    #2732
    Neil Herbert
    Participant

    So that is a different connector, the JDBC Connector will be called jdbc-connector-rabbitmq.jar.

    This can be downloaded from:

    https://download.openiam.com/release/community/4.2.0.9/connectors/jdbc-connector-rabbitmq.jar

    Follow the docs on my previous link. Ensure it has the right owner. Also ensure you configure the jdbc connector on the VM and point it at the Connector Queue listed under Webconsole → Provisioning → Connectors → JDBC Connector. You should see examples of how other connectors are configured somewhere in the /usr/local/openiam/connectors.

    #2733
    Davide Ceravolo
    Participant

    Thank you, i miss that jarfile.
    Recheck all settings and retry the connection.
    I hope this fix resolve my problem.

    #2742
    Davide Ceravolo
    Participant

    Update:
    Thank you Neil for all the support, I finally solved the issue, but it wasn’t just the missing connector.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.