Home Forums Installation Ldap-Connector-Error

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1357
    Lourenco
    Participant

    Hi Guys

    I tried to configure the ldap connector but I’m getting the following error

    ./startldapconnector.sh: line 3: -Djavax.net.ssl.trustStore=/usr/local/OpenIAM/data/openiam/conf/cacerts: No such file or directory

    ./startldapconnector.sh: line 4: -Dorg.openiam.connector.queue=LDAP_Connector_1_Request: command not found

    ./startldapconnector.sh: line 5: -Dorg.openiam.connector.queueResponseName=LDAP_Connector_1_Response: command not found

    PS: I tried the default configuration but I had the same error

    Attachments:
    You must be logged in to view attached files.
    #1362
    Ameet Shah
    Keymaster

    Hi,

    Can you share your ldap connector.sh file here?

    Regarding the question about various directories:
    /data/openiam/conf/ldap-connector-rabbitmq/certs
    /usr/local/OpenIAM/connectors/ldap-connector-rabbitmq/certs

    Both of these to directories point to the same location through a symlink
    (data -> /usr/local/OpenIAM/data)

    This is location where ldap-connector,.in 4.1.x will create the trust store.

    #1363
    Lourenco
    Participant

    Hi Ameet
    The problem was in the script: startldapconnector.sh, as you help me:
    ..remove all the extra line breaks in the file so that all of the arguments are on the same line.

    Now the ldapconnector is starting.

    Thanks a lot.
    Lourenco

    • This reply was modified 1 year, 4 months ago by Lourenco.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.