Home Forums Installation OpenIAM initial sync with AD

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2414
    Jordan Reich
    Participant

    Hi all,

    I am relatively new to the OpenIAM system and need some help to figure out how to get up and running within the system. I have successfully gotten OpenIAM installed via RPM onto CentOS-8-Stream running 4.2.0.8.

    I have gotten all of the initial suite setup and successfully logged into the HTTP FQDN without any issue. I have configured the AD PowerShell Connector and setup the managed system AD PowerShell Managed System.

    I have received a green response on the running connectors status for the aforementioned managed system. My next step was to try and synchronize data into OpenIAM from AD (users/groups). I used one of the example items provided and it has been configured as shown in the Sync_Settings_Groups.png attachment below.

    The test returns as successful.

    When I run the SYNC NOW option I get the follow errors returned:

    Nothing has been found in target system.
    PROVISIONING_USER_SEARCH
    Search called
    (&(objectClass=user)(objectCategory=person))
    Error code: INTERNAL_ERROR;error text: Response is not received from RabbitMQ during reply timeout

    I am trying to move through this setup one step at a time so any information you can provide that may help would be useful, thank you!

    • This topic was modified 9 months, 1 week ago by Jordan Reich.
    Attachments:
    You must be logged in to view attached files.
    #2421
    suneet_shah
    Keymaster

    Hi Jordan

    thanks for posting the details. The problem in the synch is that you are using a ldap filter with the powershell connector.

    We have some docs at the URL below which can help you

    https://docs.openiam.com/docs-4.2.0.8/connectorconfig/microsoft/4-adpowershell

    Take a look at the section on synchronization.

    #2460
    Jordan Reich
    Participant

    Thank you for the response and my apologies for the delay on my response. Other priorities crept up and I haven’t had the chance to get back around to this until now. I updated the information using the PowerShell connector details, I believe, in a correct manner (attachment below).

    However, I am still receiving this error when attempting to perform a SYNC (attachment below).

    I also checked the status of the RabbitMQ on the OpenIAM box and it seems to be fine? (attachment below).

    Appreciate any help you can provide! Thanks.

    Attachments:
    You must be logged in to view attached files.
    #2570
    Neil Herbert
    Participant

    Hi Jordan,

    How many groups and users are you trying to import from AD? Have you taken a look at the Powershell connector logs to see if it’s finding objects? You can find info on viewing the logs on the following page https://docs.openiam.com/docs-4.2.0.8/connectorconfig/microsoft/2-powershellconnectorsusage

    If your logs show that it finds users and groups it maybe a connection issue with rabbitMQ. More likely a timeout issue with OpenIAM not waiting long enough for the response.

    Neil

    #2571
    Neil Herbert
    Participant

    Sorry for the double post, I was too late to edit my last post. Have you tried only selecting a single user or group with your filters? It can be useful while debugging to limit the scope of what you are loading in.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.