Home Forums Installation Services Not Starting Reply To: Services Not Starting

#1766
peter hofer
Participant

Hi Would appreciate some assistance. Followed installation instructions for community OPENIAM all seems to go well , but the UI is not coming up. Waited about 20 minutes and still not up.

Have tried the install twice, with same issue using openiam_full-4.1.14-RELEASE.20201224.el7.x86_64.rpm on centos 7 (2009)

Your assistance would be appreciated.

[root@openiam ~]# service openiam status
Openiam Status report Thu Jan 21 21:51:24 GMT 2021
[OK] – openiam-esb – Service working. Application status: [ UP ]
[OK] – workflow – Service working. Application status: [ UP ]
[OK] – groovy-manager – Service working. Application status: [ UP ]
[OK] – idm – Service working. Application status: [ UP ]
[OK] – reconciliation – Service working. Application status: [ UP ]
[OK] – synchronization – Service working. Application status: [ UP ]
parse error: Invalid numeric literal at line 1, column 10
[WARNING] – openiam-ui – Service working, but Application status: [ DOWN ]. Probably it’s still starting. Please check again in few minutes
[root@openiam ~]#

I noticed Redis is not active

root@openiam logs]# systemctl status redis
● redis.service – Redis persistent key-value database
Loaded: loaded (/usr/lib/systemd/system/redis.service; disabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/redis.service.d
└─limit.conf
Active: failed (Result: exit-code) since Thu 2021-01-21 22:05:17 GMT; 19s ago
Process: 15947 ExecStart=/usr/bin/redis-server /etc/redis.conf –daemonize no (code=exited, status=1/FAILURE)
Main PID: 15947 (code=exited, status=1/FAILURE)

Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: Started Redis persistent key-value database.
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: redis.service: main process exited, code=exited, status=1/FAILURE
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: Unit redis.service entered failed state.
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: redis.service failed.
[root@openiam logs]#

When I try and start get error below.

[root@openiam logs]# service redis start
Redirecting to /bin/systemctl start redis.service
[root@openiam logs]# systemctl status redis
● redis.service – Redis persistent key-value database
Loaded: loaded (/usr/lib/systemd/system/redis.service; disabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/redis.service.d
└─limit.conf
Active: failed (Result: exit-code) since Thu 2021-01-21 22:05:17 GMT; 7s ago
Process: 15947 ExecStart=/usr/bin/redis-server /etc/redis.conf –daemonize no (code=exited, status=1/FAILURE)
Main PID: 15947 (code=exited, status=1/FAILURE)

Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: Started Redis persistent key-value database.
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: redis.service: main process exited, code=exited, status=1/FAILURE
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: Unit redis.service entered failed state.
Jan 21 22:05:17 openiam.localhost.localdomain systemd[1]: redis.service failed.
[root@openiam logs]#
[root@openiam logs]#