Home Forums Identity Governance AzureAD synchronisation

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2349
    Cedric Brousse
    Participant

    Hello,

    I tried to sync our Azure AD users in our OpenIAM instance.

    I used a connector “O365” called RemoteConnector_2
    I downloaded / installed and launched theAzureAD connector and connected it to our rabbitMQ instance with RemoteConnector_2.
    I added a managed system connected to “portal.office.com”
    I duplicated “AD USER Example” sychronisation to get a “1-Test synchronisation CBS” sychronisation with these parameters (see attachemments)

    And when I tried to sync, I have got this error :
    EVENT_NAME >> PROVISIONING_USER_SEARCH
    DESCRIPTION >> Search called
    CustomSearchQuery >> (&(objectClass=user)(objectCategory=person))
    FAILURE_REASONError code >> INTERNAL_ERROR;error text: Response is not received from RabbitMQ during reply timeout

    Can you see what’s wrong with my configuration ?

    I didn’t find any tuto to sync azure AD with openIAM. Do you know one ?

    Regards

    Attachments:
    You must be logged in to view attached files.
    #2552
    Neil Herbert
    Participant

    Hello Credic,

    I know you posted a while ago but thought I would offer a little help.

    The first thing you should check is whether your o365/Powershell connector is able to talk to rabbitMQ. Ensure ports are open and that the host you have installed the connector on can talk to it.

    If it can communicate with rabbitMQ you should take a look at the logs for the connector. You can find information on how to troubleshoot and view the logs of Powershell connectors here https://docs.openiam.com/docs-4.2.0.7/connectorconfig/microsoft/2-powershellconnectorsusage

    If you find there isn’t anything in the logs, chances are it isn’t talking to rabbitMQ and you should revisit the previous bit and check your configuration.

    If it is able to communicate and you can see it getting entries from Azure, it’s likely to be a timeout issue. How many user objects are in Azure? I believe the default timeout is 60 seconds which is definitely not enough if you are doing a full sync and have lots of users. Off the top of my head I can’t remember the exact setting you have to change but there is a Java parameter you need to change to set the timeout. I can dig it out if that is the case.

    Neil

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.